The information in this USER’S MANUAL has been carefully reviewed and is believed to be accurate. The vendor
assumes no responsibility for any inaccuracies that may be contained in this document, makes no commitment to
update or to keep current the information in this manual, or to notify any person organization of the updates.
Please Note: For the most up-to-date version of this manual, please see our web site at www.supermicro.com.
Super Micro Computer, Inc. (“Supermicro”) reserves the right to make changes to the product described in this
manual at any time and without notice. This product, including software, if any, and documentation may not, in
gf67cbbwhole or in part, be copied, photocopied, reproduced, translated or reduced to any medium or machine
without prior written consent.
IN NO EVENT WILL SUPERMICRO BE LIABLE FOR DIRECT, INDIRECT, SPECIAL, INCIDENTAL,SPECULATIVE OR
CONSEQUENTIAL DAMAGES ARISING FROM THE USE OR INABILITY TO USETHIS PRODUCT OR DOCUMENTATION,
EVEN IF ADVISED OF THE POSSIBILITY OF SUCHDAMAGES. IN PARTICULAR, SUPERMICRO SHALL NOT HAVE
LIABILITY FOR ANY HARDWARE,SOFTWARE, OR DATA STORED OR USED WITH THE PRODUCT, INCLUDING THE
COSTS OFREPAIRING, REPLACING, INTEGRATING, INSTALLING OR RECOVERING SUCH HARDWARE,SOFTWARE, OR
DATA.
Any disputes arising between manufacturer and customer shall be governed by the laws of Santa Clara County in
the State of California, USA. The State of California, County of Santa Clara shall be the exclusive venue for the
resolution of any such disputes. Super Micro's total liability for all claims will not exceed the price paid for the
hardware product.
FCC Statement: This equipment has been tested and found to comply with the limits for a Class A digital device
pursuant to Part 15 of the FCC Rules. These limits are designed to provide reasonable protection against harmful
interference when the equipment is operated in a commercial environment. This equipment generates, uses, and
can radiate radio frequency energy and, if not installed and used in accordance with the manufacturer’s instruction
manual, may cause harmful interference with radio communications. Operation of this equipment in a residential
area is likely to cause harmful interference, in which case you will be required to correct the interference at your
own expense.
California Best Management Practices Regulations for Perchlorate Materials: This Perchlorate warning applies only
to products containing CR (Manganese Dioxide) Lithium coin cells. Perchlorate Material-special handling may
apply. See http://www.dtsc.ca.gov/hazardouswaste/perchlorate/ for further details.
Manual Revision 1.0
Release Date: September 26, 2013
Unless you request and receive written permission from Super Micro Computer, Inc., you may not copy any part of
this document.
Information in this document is subject to change without notice. Other products and companies referred to
herein are trademarks or registered trademarks of their respective companies or mark holders.
This document describes the system features supported in Supermicro Layer 2 / Layer 3 switch products.
This document covers the system configurations for the below listed Supermicro switch products.
Top of Rack Switches
• SSE-G24-TG4
• SSE-G48-TG4
• SSE-X24S
• SSE-X3348S
• SBM-GEM-X2C
• SBM-GEM-X2C+
• SBM-GEM-X3S+
• SBM-XEM-X10SM
Blade Switches
• SSE-X3348T
The majority of this document applies to the above listed Supermicro switch products. In any particular
sub section however, the contents might vary across these product models. In those sections the
differences are clearly identified with reference to a particular model(s). If any particular model is not
referenced, the reader can safely assume that the content is applicable to all the above listed models.
Throughout this document, the common term “switch” refers to any of the above listed
Supermicro switch models unless a particular model is noted.
1.1 IP Overview
Internet Protocol (IP), the foundation of the IP protocol suite, is a packet-based protocol used for the
exchange of data over computer networks. IP is a network layer that contains addressing and control
information to allow routing of data packets. IP handles addressing, fragmentation, reassembly, and
protocol de-multiplexing.
Supermicro switches support both TCP and UDP at the transport layer for maximum flexibility in
services.
• Transmission Control Protocol (TCP) is a connection-oriented protocol built upon the IP layer.
TCP specifies the format of data and acknowledgments used in the transfer of data and also the
Supermicro L2/L3 Switches Configuration Guide
5
procedures used to ensure that the data arrives in correct order. With TCP, multiple applications
on a system can communicate concurrently as it handles all de-multiplexing of the incoming
traffic among the application programs.
• With UDP, applications can send messages(also called datagrams) to other hosts on an IP
network without prior setup of transmission channels or data paths. UDP is suitable when error
checking and correction is either not necessary or performed in the application, avoiding the
overhead of such processing at the network interface level.
The following features of IP implementation in Supermicro switches are covered in this document.
• Layer3 Interface
• Inter-VLAN routing
• Static Route
• ARP
• DHCP
• VRRP
1.2 Layer 3 Interface
The network layer, or Layer 3,handles the routing of data in packets acrosslogical internetwork paths.
The data link layer, or Layer 2,contains protocols that control the physical layer (Layer 1) and data
framing for transmission on the physical medium. The Layer 2 function of filtering and forwarding data
in frames between two segments on a LAN is known as bridging.
Supermicro switches support three types of Layer 3 interfaces.
• The Layer 3VLAN Interface combines the functionality of routing and bridging.
• The physical Layer 3 interface allows the switch to be configured like a traditional router. It is
also referred as a Routed Interface.
• The Loopback Interface is a logical interface that is “always up”. It is not tied to any physical
interface therefore it does not go down unless it is administratively shut down.
The Layer3 interface is used to:
• Allow traffic to be routed between VLANs.
• Provide Layer 3 IP connectivity to the switch.
1.2.1 Physical L3 Interface
The physical Layer 3 interfaces support functionalities similar to a traditional router. Routed ports are
physical ports on the switch that act like a router interface with an IP address configured; they do not
belong to any VLAN.
Supermicro switches support Secondary IP addresses, which are used when the same physical segment
of the switch interface that is connected serves multiple logical networks.
Supermicro L2/L3 Switches Configuration Guide
6
Step 1
configure terminal
Enters the configuration mode
Step 2
interface
<
interface
-
type
><
interface
-id>
Enters
the interface configuration
Step 3
no switchport
Configure
s the
router port
Step 4
ip address [<ip
-
address> | <ip
-
address>/prefix
-
Configure
s the
IP address.
Follow the steps below to configure a Physical Layer3 Interface.
Step Command Description
or
interface range <interface-type><interface-id> ….
mode.
1.2.2
interface-type – may be any of the
following:
gigabitethernet – gi
extreme-ethernet – ex
qx-ethernet – qx
1.2.3
interface-id is in slot/port format for all
physical interfaces.
To configure multiple interfaces, use
the “interface range …” command. To
provide a range use a hyphen (-)
between the start and end interface
numbers. E.g.: int range gi 0/1-10
length] [<subnet-mask>] [secondary]
1.2.4
To provide multiple interfaces or
ranges, separate with a comma (,).
E.g.: int range gi 0/1-10, gi 0/20
1.2.5
If multiple interfaces are provided, the
next step will perform the particular
configuration on all these interfaces.
ip-address – A valid IPv4 address.
ip-address/prefix-length - A valid IPv4
Supermicro L2/L3 Switches Configuration Guide
7
a
ddress with a prefix length of value 1
-
Step 5
end Exi
ts the configuration mode.
Step 6
show
ip interface
Displays the
Layer 3
interface
IP Routing is enabled by default in Supermicro switches.
32.
subnet-mask – A valid IP subnet mask.
1.2.6
Secondary - Assigns multiple IP
addresses to network interfaces.
1.2.7
information.
The “switchport” command deletes the Physical Layer 3 interface and the interface is reset
as a Layer2 interface.
The example below shows the commands used to configure a Physical Layer3 Interface.
SMIS# configure terminal
SMIS(config)# interface Gi 0/22
SMIS(config-if)# no switchport
SMIS(config-if)# ip address 20.20.20.1 255.255.255.0
SMIS(config-if)# end
SMIS# show ip interface
Gi0/22 is up, line protocol is up
Internet address is 20.20.20.1/24
Broadcast address is20.20.20.255
mgmt is up, line protocol is down
Internet address is 192.168.100.102/24
Broadcast address is192.168.100.255
Gateway 0.0.0.0
1.2.8 Layer 3 VLAN Interface
VLANs typically operate at Layer 2. When aLayer2 VLAN is configured with an IP address, it behaves as a
logical Layer 3 VLAN interface. A L3 VLAN interface provides logical routing interfaces to VLANs on Layer
Supermicro L2/L3 Switches Configuration Guide
8
Step 1
configure terminal
Enters the co
nfiguration mode
Step 2
Create a Layer 2 VLAN and add all required ports.
For details on configuring
a
Layer 2
Step 3
interface
vlan<vlan
-
id (1
-
4069)>
Entersthe
interface configuration mode
Step 4
ip address [<ip
-
address> | <ip
-
address>/prefix
-
Configure
s the
IP address.
Step
5 end Exits the configuration mode.
Step
6 show
ip interface
Displays the Layer 3 interface
The “
no ip address [<ip_addr>]
”
command
deletes the
L
ayer 3 VLAN interface and
resets
it
2 switches.It is also called aSwitch Virtual Interface (SVI )and handles processing for all the packets
associated with that VLAN.
Follow the steps below to configure a Logical Layer3 Interface.
Step Command Description
VLAN, refer to the ‘VLAN Config. guide’
at www.supermicro.com
to specify the interface to be
configured as a Layer 3 interface.
length] [<subnet-mask>] [secondary]
ip-address – A valid IPv4 address.
ip-address/prefix-length - A valid IPv4
address with a prefix length of value 1-
32.
subnet-mask – A valid IP subnet mask.
Secondary - Assigns multiple IP
addresses to network interfaces.
information.
as a Layer2 VLAN.
The example below shows the commands used to configure a Logical Layer3 interface.
SMIS(config)# interface vlan 10
SMIS(config-if)#ip address 10.10.10.1 255.255.255.0
SMIS(config-if)# end
Supermicro L2/L3 Switches Configuration Guide
9
Step 1
configure terminal
Enters the configuration mode
Step
2 interface
loopback <interface
-
id (1
-
100)>
Enters
interface configuration mode
to
Step
3 ip address [<ip
-
address> | <ip
-
address>/prefix
-
Configure IP address.
Step 4
no shutdown
Enable the
l
oopback interface
S
tep 5
end Exits the configuration mode.
Step
6 show ip interface
Displays the
Layer 3 interface
SMIS# show ip interface
mgmt is up, line protocol is down
Internet address is 192.168.100.102/24
Broadcast address is 192.168.100.255
Gateway 0.0.0.0
vlan10 is up, line protocol is up
Internet address is 10.10.10.1/24
Broadcast address is 10.10.10.255
1.2.9 Loopback Interface
Supermicro switches support a loopback interface, which is a virtual interface and is not connected to
any other device. Loopback interfaces are very useful since they will never go down unless the entire
router goes down. This is useful for managing routers because there will always be at least one active
interface on the routers: the loopback interface.
Follow the steps below to configure loopback interface.
Step Command Description
specify the interface to be configured
as a Layer 3 interface.
length] [<subnet-mask>]
ip-address – A valid IPv4 address.
ip-address/prefix-length - A valid IPv4
address with a prefix length of value 1-
32.
subnet-mask – A valid IP subnet mask.
NOTE: Subnet mask should be 32-bit for loopback interface.
show interface loopback <1-100>
configuration.
Display the loopback interface
Supermicro L2/L3 Switches Configuration Guide
10
configuration.
IP Routing is not supported on
l
oopback
i
nterfaces.
The “nointerface loopback <interface-id (1-100)>” command deletes the loopback
interface.
SMIS# configure terminal
SMIS(config)# interface loopback 1
SMIS(config-if)# ip address 100.1.1.1/32
SMIS(config-if)# no shutdown
SMIS(config-if)# end
mgmt is up, line protocol is down
Internet address is 192.168.100.102/24
Broadcast address is 192.168.100.255
Gateway 0.0.0.0
loopback1 is up, line protocol is up
Internet address is 100.1.1.1/32
Broadcast address is 100.1.1.1
1.3 Inter-VLAN Routing
VLANs enable splitting traffic across several manageable broadcast domains. Devices within a VLAN can
communicate with one another without requiring routing. Whenever hosts in one VLAN need to
communicate with hosts in another VLAN, the traffic must be routed between them. This is known as
Inter-VLAN Routing.
Supermicro switches use application-specific integrated circuits (ASICs), which are hardware chips that
can route traffic at very high speeds. These ASICs are installed on the switching engine of a Layer 3
switch, which traditionally switches frames at Layer 2. The ASICs allow the switching engine to also
switch frames that contain packets sent between different VLANs. Each ASIC is programmed with the
information required to route traffic from one VLAN to another, without having to pass the traffic through the CPU of the routing engine.
Advantages of Inter-VLAN routing in L3 switches:
Supermicro L2/L3 Switches Configuration Guide
11
To WAN via Router
• Layer 3 switches are much more cost effective than routers for delivering high-speed inter-VLAN
routing.
• Layer 3 switches are enhanced Layer 2 switches, and therefore have the same high port
densities as Layer 2 switches. Routers on the other hand typically have a much lower port
density.
• Layer 3 switches can be configured to operate as a normal Layer 2 switch or Layer 3 switch as
required.
Application of Inter-VLAN routing:
The network can be divided based on the group or function of itsdevices. For example, an engineering
department VLAN would only have devices associated with the engineering department, while an HR
VLAN would only have HR related devices. With Inter-VLAN routing, the devices in each VLAN can talk to
one another without all the devices being in the same broadcast domain.
VLAN 300
VLAN 100
VLAN 200
Layer3
Figure IP-1: Inter-VLAN Routing
Follow the steps below to configure Inter-VLAN routing.
1. Create two Layer 3 interface VLANs.
2. Configure an IP address for both interfaces of these Layer 3 VLANs.
3. Execute show ip route to check if the VLAN routes specified by VLAN IP address are displayed as
connected routes. The routing table has an entry for each VLAN interface subnet, therefore,
devices in VLAN 10 can communicate with devices in VLAN 20 and vice versa.
The example below shows the commands used to configure Inter-VLAN routing.
SMIS# configure terminal
Loading...
+ 23 hidden pages
You need points to download manuals.
1 point = 1 manual.
You can buy points or you can get point for every manual you upload.