Wellgate 2644 User Manual

Page 1
Wellgate 26xx Series
VoIP Gateway
User Manual
Revision Information
Version Date Description
nd
English Version
1. Introduction ...................................................................................................... 3
1.1 26xx Telephony Gateway.................................................................................. 3
1.2 Benefits .......................................................................................................... 3
1.3 Physical Interface............................................................................................. 3
1.4 Specification.................................................................................................... 4
1.5 Setting and maintenance.................................................................................. 5
1.6 Environmental ................................................................................................. 5
Page 2
26xx Technical Manual EN-V106d
1
2. Appearance ....................................................................................................... 6
2.1 Front Panel: LED Indicators ............................................................................ 6
2.2 Rear Panel: LED Indicators ............................................................................. 7
3. Environment Setup and IP Connection ................................................................ 9
3.1 Configuration................................................................................................... 9
3.2 Network Configuration ................................................................................... 11
3.2.1 WAN Setting ............................................................................................... 12
3.2.1.1 WAN Setting --Static IP......................................................................................... 14
3.2.1.2 WAN Setting --DHCP............................................................................................ 15
3.2.1.3 WAN Setting --PPPoE ...........................................................................................16
3.2.2. LAN Setting ............................................................................................... 17
3.3 General configuration..................................................................................... 19
3.3.1 PABX Mode (Just use 2644 only).................................................................. 19
3.3.2.1 SIP Setting............................................................................................... 20
3.3.3 SIP Advanced Setting .................................................................................. 23
3.3.4 Payload Type Setting ................................................................................... 26
3.3.5 Line Setting ................................................................................................ 27
3.3.6 Qos Setting................................................................................................. 30
3.3.7 Speed Dial Setting....................................................................................... 31
3.3.8 Caller ID Setting ......................................................................................... 32
3.3.9 CDR Setting ................................................................................................ 34
3.3.10 Syslog Setting ........................................................................................... 35
3.4 Advanced Configuration ................................................................................. 37
3.4.1 System setting ............................................................................................ 37
3.4.2 SNTP Setting .............................................................................................. 41
3.4.3 Codec Setting ............................................................................................. 42
3.4.4 Voice Setting............................................................................................... 44
3.4.5 Tone Setting ............................................................................................... 46
3.4.6 Phone Setting ............................................................................................. 48
3.4.7 Digit Manipulation ....................................................................................... 50
3.4.8 Dial Plan..................................................................................................... 52
3.4.9 Call routing Editor ....................................................................................... 54
3.5 Management ................................................................................................. 55
3.5.1 Provision Server .......................................................................................... 55
3.5.2 Save-Reload setting..................................................................................... 56
3.5.3 Voice File.................................................................................................... 57
3.5.4 Upgrade Firmware....................................................................................... 58
3.5.5 Reset to Default.......................................................................................... 59
Page 3
26xx Technical Manual EN-V106d
2
3.5.6 Network Status ........................................................................................... 60
3.5.7 Version Info. ............................................................................................... 61
3.5.8 Port Status ................................................................................................. 62
3.5.8 Password.................................................................................................... 63
3.6 Rebooting the system .................................................................................... 64
Appendix A: How to set the P2P call ...................................................................................65
Page 4
26xx Technical Manual EN-V106d
3
1. Introduction
1.1 26xx Telephony Gateway
The Wellgate 26xx is an 4 to 8-ports FXS/FXO VoIP gateway which includes 1-WAN/4-LAN 10/100 base-T NAT router to meet the current network environment. Field-proven quality of Voice communication and Fax transmission over IP broadband access network to makes Wellgate 26xx series to be an excellent solution for various VoIP applications.
1.2 Benefits
Ideally suited for Enterprise use, rich-feature designed to inter-work with
IP-PBXs for small and middle enterprises.
Carrier-grade features are supported and tested to be fully interoperable with
leading Soft-Switches.
Provide CDR for call shop application. Superb device for apartment VoIP service.
1.3 Physical Interface
Ethernet port (RJ-45, 10/100 base-T)
1-WAN port, for connect to router, ADSL modem (ATU-R), or switch hub
directly.
4-LAN port, for PC or other network devices connecting.
Telephony port (RJ-11) --- depending on different models
8-FXS ports, to connect with analog phone 8-FXO ports, to connect with PSTN 4-FXO/4FXS ports, to connect with PSTN and analog phone 4 FXO ports, to connect with PSTN
4 FXS ports, to connect with phone Reset button (Factory Default) AC power Jack Status indicated LED
Indicates Ethernet, FXS, and SIP system status
Page 5
26xx Technical Manual EN-V106d
4
1.4 Specification
IP Network connection
IPv4 (RFC 791)
MAC Address (IEEE 802.3)
PPPoE Client (RFC 2516)
DNS Client
DHCP Client (RFC 2131)
DHCP Server (RFC 2131)
NAT (RFC 1631)
TCP/UDP (RFC 793/768)
ICMP (RFC 792)
RTP/RTCP (RFC 1889/1890)
SNTP (RFC 2030)
TFTP Client
Telnet Server
HTTP Server
QoS – 802.1Q Virtual LANs
DiffServ (RFC 2475) / ToS (RFC 791/1349) IP Telephony (VoIP)
SIPv2 (RFC 3261)
- Session Timer (RFC 4028)
- Privacy Mechanism (RFC 3323)
- Outbound proxy setting for increasing performance, productivity,
and security.
- SIP proxy redundancy- Support Primary and Secondary proxy.
Voice Codecs
- G.711 (a-Law/u-Law): 64k bits (PCM)
- G.723.1: 6.3k/5.3k bits
- G.729A: 8k bits (CS-SCELP)
VAD – Voice Activity Detection with Silence Suppression
CNG – Comfortable Noise Generation
Echo Cancellation (G.165/G.168)
Jitter Buffer – Adaptive & Configurable
Packet Loss compensation - increasing voice quality
DTMF: In-band, Out-of-band (RFC 2833), and SIP-Info
Caller Generation/Detection – FSK, DTMF
FAX transmission
Page 6
26xx Technical Manual EN-V106d
5
- G.711 pass-through
- T.38 Fax relay protocol
Tone Generation & Detection
- Ringing Tone
- Ring Back Tone
- Dial Tone
- Programming Tone
Call Features
- Call Hold
- Call Transfer (Blind & consultant)
- Call Forward (Unconditional / No Answer / Busy)
MWI – Message Waiting Indication
PSTN Routing Prefix (2644 only)
PSTN Bypass when network or system failure (2644 only)
IP line hunting
Adjustable volume level Security
HTTP 1.1 basic/digest authentication for WEB access
MD5 for SIP authentication (RFC 2069/2617)
Password protected Admin access authority
1.5 Setting and maintenance
Configure & Update method
- Web Browser (HTTP)
- Telnet
- FTP/TFTP
Setting parameter Import /Export Voice announcement of IP address Syslog Client – Debug & CDR (Call Detail Record)
1.6 Environmental
Dimension: 35 × 242 × 160 mm (Desktop)
Weight: 0.935kg (unit) Operating Temp. & Humidity
- Temp.: 0℃~45℃ (32℉~113℉)
- Humidity: 10%~85% relative humidity, non-condensing
Page 7
26xx Technical Manual EN-V106d
6
Storage Temp. & Humidity
- Temp.: 0℃~55℃ (32℉~131℉)
- Humidity: 10%~95% relative humidity, non-condensing
AC Power Adaptor:
- INPUT: AC100V-240V, 50/60Hz
- OUTPUT: DC 12V, 3.0A
Regulatory Compliance: FCC (Part 15, Class B) & CE
2. Appearance
2.1 Front Panel: LED Indicators
Wellgate 2608
Wellgate 2680
Wellgate 2644
LED Description
Power When the power adapter is connected, the LED will light up
green.
Ready When system is startup successfully, the LED will light up
green.
Proxy When the gateway is registered successfully to a Proxy, this
will light up green.
WAN This will light up green when the gateway’s WAN port is
physically connected to the public internet. When data is transmitted through this port, it will flash green. The default IP of WAN port is 10.1.1.3.
Page 8
26xx Technical Manual EN-V106d
7
LAN (1-4) This will light up green when the gateway’s LAN port 1-4 is
physically connected to a local network (Refer to Rear Panel section in page number for location of LAN port 1-4). When data is transmitted through this port, it will flash green. The default IP of LAN port is 192.168.123.123.
T1-T8 The status LED for FXS port 1-8, this will light up amber
orange when the connected phone’s handset is lifted, or when the connected phone is engaged in a conversation. It will flash amber orange when there is an incoming call.
L1-L8 The status LED for FXO port 1-8. When there is no PSTN
connected, this LED will become blinking. when PSTN is connected and no talking, the LED will be off. When a line is using, the LED will become light up.
2.2 Rear Panel: LED Indicators
Wellgate 2608
Wellgate 2680
Wellgate 2644
Item Description
Reset Press and hold over 5 seconds to reload factory default
setting, this will erase all the settings configured on the gateway.
T1-T8 The RJ-11 FXS port 1-8, connects analog phone sets, trunk
Page 9
26xx Technical Manual EN-V106d
8
line in PABX.
L1-L8 The RJ-11 FXO port 1-8, connect to PSTN
T1/P1-T4/P4 It is a pair of FXO and FXS connector. The different is that the
when power off or application is crashed, the FXO and FXS will be connected together automatically for local surviving.
LAN 1-4 10/100 Base-T RJ-45 socket for LAN port 1-4, connects to
local area network.
WAN 10/100 Base-T RJ-45 socket for WAN port, connects to wide
area network.
DC 12V The power socket, input AC 100V~120V; output DC12V.3A
Page 10
26xx Technical Manual EN-V106d
9
3. Environment Setup and IP Connection
First of all, connect your computer to Wellgate 26xx’s LAN port by using DHCP. The IP address assign to your computer should be 192.168.123.x by default. Once you can get the IP address from Wellgate 26xx, you can start the configuration as below.
3.1 Configuration
Login to the WELLGATE 26XX web configuration menu
1. Open your WEB browser and key in the default IP address of the gateway
(http://192.168.123.123) in the Address box (see figure below).
3. You will see a pop-up window requesting username and password before you can login to the web configuration menu. Username is “root” while password is blank “ “ (see figure below).
Page 11
26xx Technical Manual EN-V106d
10
2. You will enter the main page of the web configuration interface after you
keyed in the username and password correctly (see figure below).
Page 12
26xx Technical Manual EN-V106d
11
3.2 Network Configuration
The following instructions will explain the configurations for setting up the WAN port of the 26xx. There are in total three methods of connections: Static IP, DHCP and PPPoE.
Note: You can retrieve the IP address of the WAN port by keying #126# on the phone set that is connected to the FXS port of the gateway. You will hear an IVR announcing the current IP address of the WAN port.
Page 13
26xx Technical Manual EN-V106d
12
3.2.1 WAN Setting
The table shown below describes the configuration items for 3 connection types of network (Static IP, DHCP and PPPoE).
Page 14
26xx Technical Manual EN-V106d
13
WAN Setting
Item Description Static IP DHCP PPPoE
Connected mode Select the connection method
for the WAN port of the 26xx, you can choose the following:
Static IP DHCP PPPoE
V V V
Current IP Address Show current IP address V V V
DNS server mode Select the DNS behavior, you
can choose the following:
Auto Manual
“DNS auto” will retrieve the DNS information sent from the DHCP server. “Manual” will look at the specified Primary and Secondary DNS address.
V V V
Primary DNS address Specify the address of the
Primary DNS.
V V V
Secondary DNS address
Specify the address of the Secondary DNS.
V V V
WAN Link Speed Select the connection speed
for the WAN port of the 26xx, you can choose the following:
Auto 100M 10M
V V V
HTTP port for WEB management
Specify the port number for WEB management, the allowable range is 80,1024~65535.
V V V
IP address Specify the IP address. V
Subnet mask Specify the subnet mask. V
Page 15
26xx Technical Manual EN-V106d
14
WAN Setting
Item Description Static IP DHCP PPPoE
Default gateway Specify the IP address of the
default gateway.
V
Remote access restriction
Restricts/Blocks users connecting to the WAN port’s IP remotely, you can
Enable/Disable this option.
V V V
PPPoE userID Specify the username of the
PPPoE account
V
PPPoE password Specify the password
associated to the PPPoE account above.
V
Reboot after remote host disconnection
When the remote host (PPPoE) fails, the gateway will retry 3 times to reconnect, if there is no reply from the remote host within 3 tries, then the gateway will reboot. You can
Enable/Disable this option.
V
3.2.1.1 WAN Setting --Static IP
Page 16
26xx Technical Manual EN-V106d
15
1. Press the “Apply” button (at the bottom) after you finish to save changes.
2. Press the “Reboot” button to apply the changes.
3.2.1.2 WAN Setting --DHCP
1. Press the “Apply” button (at the bottom) after you finish to save changes.
2. Press the “Reboot” button to apply the changes.
P.S. When you are using DHCP in WAN and not connected, please make sure you connect Ethernet before use PC to connect to LAN port.
Page 17
26xx Technical Manual EN-V106d
16
3.2.1.3 WAN Setting --PPPoE
1. Input PPPoE user ID and password
2. Press the “Apply” button (at the bottom) after you finish to save changes.
3. Press the “CANCEL” button (next to the Apply button) to clear the values in
the page.
4. Press the “Reboot” button to apply the changes.
Page 18
26xx Technical Manual EN-V106d
17
3.2.2. LAN Setting
LAN Setting
ITEM Description
LAN IP address Specify the IP address of the 26XX LAN
port.
LAN mask address Specify the mask address for 26XX
LAN port.
DHCP server Enable/Disable DHCP function on
the LAN port. Once enabled, the LAN ports will function as a DHCP server, network devices connected to them will be issued with IP addresses.
IP address from When DHCP is enabled, you can
specify the IP address to start from when assigning to attach network devices.
IP address to When DHCP is enabled, you can
specify the ending IP address assigned to the attached network devices.
Page 19
26xx Technical Manual EN-V106d
18
LAN Setting
ITEM Description
Domain Name You can specify the domain name that
will be assigned by the DHCP server to the attached network devices. The DHCP server will send information on the “server host name” to the DHCP client.
Lease time(sec) You can specify the maximum lease
time of the IP address allocated to the DHCP client.
DNS server mode Select the DNS behavior, you can
choose the following:
Auto Manual
“DNS auto” will retrieve the DNS information sent from the DHCP server. “Manual” will look at the specified Primary and Secondary DNS address.
Primary DNS address Specify the address of the Primary
DNS.
Secondary DNS address Specify the address of the Secondary
DNS.
1. Press the “Apply” button (at the bottom) after you finish to save changes.
2. Press the “Reboot” button to apply the changes.
Page 20
26xx Technical Manual EN-V106d
19
3.3 General configuration
To make VoIP calls, you will need a SIP account provided by the SIP Proxy you are registered with. To configure the relevant SIP settings, please refer to the instructions explained below.
3.3.1 PABX Mode (Just use 2644 only)
This quick setting is dedicated to be used for Wellgate 2644 to become a inter-connection in between PSTN and traditional PABX. The call scenario will be working as below:
1. For FXO incoming call, it will route to corresponding FXS directly (1 by 1)
2. For FXS outgoing call, it will route to VOIP except those prefix set in FXO dialing Prefix.
3. For VOIP incoming call, it will route to FXS based on the called number
4. When VOIP call is failed to be called out such as register fail or network issue, the call will be route to FXO as backup.
5. When Wellgate 26xx is malfunction or power failure, the all call will be directly bypassed to FXO.
Page 21
26xx Technical Manual EN-V106d
20
PABX Connection To enable PABX behavior or not.
SIP Setting Please refer to 3.3.2.1
Representative Number Configuration It is used when you only have a SIP
account to be shared for FXS lines. Please refer to 3.3.2.1
Primary FXS SIP settings When you have multiple SIP accounts
for each FXS line, please set Representative Number Only to No. Then refer to 3.3.2.1 for the detail
FXS SIP Setting FXS line SIP account settings
Hunting Select the group of representative
number, and specify the priority. Only the checked line will become the member of the representative number. The default setting L1~L2 is grouped.
3.3.2.1 SIP Setting
Page 22
26xx Technical Manual EN-V106d
21
Primary proxy Specify the data of primary proxy:
Enable/Disable, IP address, Port#, Domain Name, Expire time and MWI TTL.
Secondary proxy Specify the data of secondary proxy:
Enable/Disable, IP address, Port#, Domain Name, Expire time and MWI TTL. When you enable secondary proxy, it will start to register no matter whether primary proxy is registered or not. However, it will be used only when primary proxy is not registered or the incoming call is coming from it.
Outbound proxy Specify the data of Outbound proxy:
Enable/Disable, IP address and Port#.
Secondary Outbound proxy Specify the data of Outbound proxy for
secondary proxy: Enable/Disable, IP address and Port#.
Representative Number The representative number is working
as a SIP trunk for the selected FXS line (for all FXS or FXO/FXS combination model) or FXO line (for all FXO model). When an incoming call to the representative number, the selected FXS or FXO port will be hunted.
Enable Enable the Line, the default setting is
“Enable” and it will Register or Unregister to SIP Proxy
Account Input the SIP Proxy registration
account ID.
Number Input the phone number.
Password Input the password of IP Proxy
registration account ID.
Display name Specify the Display name of the phone
number
Forward Specify the Representative forwarding
type to be used, only choose busy
Forward Number Specify the number to be forwarded
Page 23
26xx Technical Manual EN-V106d
22
when the specified forward condition is met.
Ring Type Select the Ring Type of representative
number. You can choose the following: Serial ring (Follow the ring priority
defined below)
Simultaneous(ring all)
Ring Time (s) for Serial ring Specify the Ring Time for Serial ring
Status Displays the registration status,
whether it is registered or not.
Hunting Select the group of representative
number, and specify the priority. Only the checked line will become the member of the representative number. The default setting L1~L2 is grouped.
1. Enter the IP address and port number of the SIP proxy into the Primary proxy address and Port fields. Press the “Apply” button to save changes.
2. Press the “Reboot” button to apply the changes.
Page 24
26xx Technical Manual EN-V106d
23
3.3.3 SIP Advanced Setting
Local SIP port(1~65535) Specify the local starting SIP port.
Each account’s interval is 2. For example, the local SIP port is set to
5060. The following is the port number to be used for 26xx: Port 1: 5060 Port 2: 5062 Port 3: 5064 Port 4: 5066 Port 5: 5068 Port 6: 5070 Port 7: 5072 Port 8: 5074 Representative Number: 5076
Local RTP port(1~65535) Specify the local starting RTP port
number.
Page 25
26xx Technical Manual EN-V106d
24
Session Expire(Sec) Specify the session expire time that
will be used to negotiate with the remote host or proxy.
Min Session Expire(Sec) Specify the minimum session expire
time that other host or proxy will need to follow when calling the WELLGATE 26XX.
Session Refresh Request Select the session refresh method that
will be used on the WELLGATE 26XX, you can choose among the two methods:
UPDATE Re-Invite
Session Refresher Select who will perform the refreshes,
you can choose among the two methods:
UAC (Client) UAS (Server)
This will add the parameter refresher=uac or uas in the Session Refresh Request message.
Unregister All Send SIP unregister signaling message
after the 26xx has been restarted
Early media Treatment Use early media treatment SIP
protocol, where SIP invite messages will not include SDP.
Support SIP Ping Special feature used with only
Nortel’s SIP proxy.
IP Anonymous Caller ID When this feature is Enabled, all IP
outgoing calls’ Caller ID will not be displayed to the destination.(Please
make sure your proxy server or soft switch supports the feature, if the proxy does not support it and you enable this feature, all IP outgoing calls will be dropped.)
When Disabled, all IP outgoing calls’ Caller ID will be displayed to the
Page 26
26xx Technical Manual EN-V106d
25
destination.
Support Message Waiting Indication (MWI)
You can Enable or Disable the MWI function.( This feature is for FXS only)
SIP Message Resend Timer Base (sec) Specify the resend time in seconds for
each SIP request message that has not received a response.
Max. Response Time for Invite (1~30sec)
Specify the timeout period for SIP Invite messages. For example, if the timeout period is 10 seconds, when the 26xx sends an Invite message and does not receive a response within 10 seconds, it will cancel the call.
SIP/RTP Encrypt This function can encrypt the SIP and
RTP message but only supports Wellgate sever proxy.
1. Press the “Apply” button (at the bottom) after you finish to save changes.
2. Press the “Reboot” button to apply the changes.
Page 27
26xx Technical Manual EN-V106d
26
3.3.4 Payload Type Setting
RFC2833 payload type Specify the RFC2833 payload type
(range is 96~128, however 100, 102~105 is reserved by other payload types).
FAX bypass payload type Specify the FAX payload type (range is
96~128, however 100, 102~105 is reserved by other payload types)
Modem by pass payload type Specify the Modem by pass payload
type (range is 96~128, default value is
103. 100, 102, 104, 105 is reserved by other payload types).
1. Press the “Apply” button (at the bottom) after you finish to save changes.
2. Press the “Reboot” button to apply the changes.
Page 28
26xx Technical Manual EN-V106d
27
3.3.5 Line Setting
Page 29
26xx Technical Manual EN-V106d
28
No Answer Forward Time (FXS only) If you enable the No Answer Forward
function (Representative number or L1~L8 number), please specify the time of no answer. The default setting is 30 sec.
FAX Enable/Disable FAX T.38 function.
Line1~Line8 relevant data
Type Displays the port type of that particular
line.
Enable Enable the line or not
Reg Register or Unregister to SIP Proxy
Number Displays the line numbers that specified
in SIP Setting. Account: Input the SIP Proxy registration account ID.
Number: Input the phone number. Password: Input the password of IP
Page 30
26xx Technical Manual EN-V106d
29
Proxy registration account ID. Display name: Specify the Display name of the phone number. The first is the number registers to Primary proxy. The default setting is 1000~1007.
Enable Hotline Click the check box to enable hotline
feature. If enabled, The check box will
display as .
Hotline Number Specify the number to forward the call to
when the Hotline feature is enabled.
Wait to Hotline(sec) Specify the time (sec) for wait to hotline,
the default value is 0.
Forward Type (FXS only) Specify the forwarding type to use, you
can choose the following:
Disable Unconditional Busy No Answer Busy and No Answer
The “Disable” option will allow you to disable this particular function.
Forward Number Specify the number to forward the call to
when the call forwarding feature is enabled.
Call Waiting (FXS only) Enable/Disable per-line Call Waiting
function.
DND (FXS only) Enable/Disable per-line DND (Do Not
Disturb) function.
Greeting (FXO only) Enable/Disable Greeting for FXO
1. Press the “Apply” button (at the bottom) after you finish to save changes.
2. Press the “Reboot” button to apply the changes.
Page 31
26xx Technical Manual EN-V106d
30
3.3.6 Qos Setting
Type Select Qos Type: DSCP or ToS
Differentiated Services Code Point Setting (DSCP)
DSCP RTP Select the DSCP value for RTP (voice
packets), the value in the drop down list is expressed in binary format, you can choose to meet your network environment.
DSCP Signal Select the DSCP value for SIP
message, the value in the drop down list is expressed in binary format, you can choose to meet your network environment.
ToS Setting
ToS RTP Select the ToS value for RTP (voice
packets), the value in the drop down list is expressed in binary format, you can choose to meet your network environment.
ToS Signal Select the ToS value for SIP messages,
the value in the drop down list is expressed in binary format, you can
Page 32
26xx Technical Manual EN-V106d
31
choose to meet your network environment.
1. Press the “Apply” button (at the bottom) after you finish to save changes.
2. Press the “Reboot” button to apply the changes.
3.3.7 Speed Dial Setting
Speed Dial Editor Specify the speed Dial
Number/Telephone Number/Name, then press the Add or Del button to add or delete record
Page 33
26xx Technical Manual EN-V106d
32
3.3.8 Caller ID Setting
Caller ID Setting (Line 1~Line 8) Select the (Line 1~Line 8)Caller ID
generation type to use, you can choose the following:
Disable DTMF FSK(Bellcore) ETSI(Before Ring) ETSI(Between ring)
FXO only choose Enable/Disable the caller ID detection
AUTO: You can choose different caller
ID type by line. If Line1~Line 8 uses the same type, you only need to set line 1 and click the “Auto” button, then
Page 34
26xx Technical Manual EN-V106d
33
the other lines will set the same type automatically. The “Disable” option will allow you to disable this particular function.
DTMF Caller ID Start Symbol Specify the DTMF Caller ID Start
Symbol The default symbol is D.
DTMF Caller ID End Symbol Specify the DTMF Caller ID End Symbol
The default symbol is C.
1. Press the “Apply” button (at the bottom) after you finish to save changes.
2. Press the “Reboot” button to apply the changes.
Page 35
26xx Technical Manual EN-V106d
34
3.3.9 CDR Setting
CDR mode Select the CDR mode for Enable or
Disable. If you Enable this feature,
please specify the CDR Server address and port number at the CDR server address and port’s text box, then you can get Call Detail Data form CDR Server.
CDR Server address If you Enable the CDR mode, please
specify the IP address of CDR Sever for data storage.
CDR Server port Specify the CDR Server port number,
The default port number is 514.
1. Press the “Apply” button (at the bottom) after you finish to save changes.
2. Press the “Reboot” button to apply the changes.
P.S.
To receive the SYSLOG CDR, you need to have a syslogd server to collect the
CDR from Wellgate 26xx. The following is a tool you can be used for testing
purpose which can be downloaded from http://tftpd32.jounin.net/
. You need to
Page 36
26xx Technical Manual EN-V106d
35
enable syslog server from settings before you can use it.
3.3.10 Syslog Setting
This syslog is used to send the debug log from Wellgate 26xx to syslog server.
Page 37
26xx Technical Manual EN-V106d
36
Syslog mode Select the Syslog mode for Enable or
Disable. If you Enable this feature,
please specify the Syslog Server address and port number at the Syslog server address and port’s text box, then you can get detail system log from Syslog server.
Syslog Server address If you Enable the Syslog mode, please
specify the IP address of Syslog Sever for data storage.
Syslog Server port Specify the Syslog Server port number,
The default port number is 514.
1. Press the “Apply” button (at the bottom) after you finish to save changes.
2. Press the “Reboot” button to apply the changes.
P.S:
To receive the SYSLOG debug information, you need to have a syslogd server to collect the debug information from Wellgate 26xx . The following is a tool you can be used for testing purpose which can be downloaded from http://tftpd32.jounin.net/. You need to enable syslog server from settings before you can use it.
Page 38
26xx Technical Manual EN-V106d
37
3.4 Advanced Configuration
3.4.1 System setting
prack PRACK is defined in RFC 3262:
Reliability of Provisional Responses in SIP. You can accommodate your softswitch (Proxy Server) to Enable or Disable this feature.
ROH (FXS only) Receiver-Off-Hook (ROH) Tone
A ROH tone is sent to the subscriber to inform him that his receiver is off-hook. You can Enable/Disable this option.
Send billing signal (FXS only) Enable Polarity Reversal for FXS as
billing signal or not. When a FXS calls to VOIP and answered by the VOIP, 26xx will generate reverse signal to FXS as billing start. When VOIP side disconnect first, 26xx will reverse back as billing stop signal.
T.38 NoAttribute No attribute (Fax version, Bit Rate,
Page 39
26xx Technical Manual EN-V106d
38
Buffer, Datagram…) indicated in T.38 Re-Invite with Session Description Protocol (SDP). You can Enable/Disable this option.
FAX redundancy depth Specify the resend times (0~3)for FAX
error packet,
T.38 FAX Type Select the FAX Type to use, you can
choose the following:
T.38
ByPass
Auto
T.30 FAXByPass Codec Select the FAX ByPass Codec to use,
you can choose the following:
G.711 a-law
G.711 u-law
Flash key function (FXS only) Select the function of Flash key, you
can choose the following:
Disable
Transfer
SIP Message
Keypad DTMF type Select the type of Keypad DTMF, you
can choose the following:
In-Band
RFC2833
SIP Info
End of dial key Select the End of dial key, you can
choose the following:
Disable
*
#
DTMF Detection Sensitivity Specify the grade of DTMF Detection
Sensitivity, the value range is (1~5)
Dial Wait Timeout (1~60sec) Specify the duration of dial waiting
when the receiver is off hook. The range is 1~60 sec.
Inter Digits Timeout (1~5sec) Specify the interval of input digits, if
the interval is over the setting, the
Page 40
26xx Technical Manual EN-V106d
39
system will end the dial and send out the DTMF. The limitation range is 1~5sec.
FAXByPass Keyword Some SIP Proxy need specify special
keyword for FAXByPass function. Input the data as SIP Proxy required.
FAXByPass Keyword Some SIP Proxy need specify special
keyword for FAXByPass function. Input the data as SIP Proxy required.
IP Address announcement You can Enable/Disable this function,
If you select Enable, you can connect T1 port with a phone set and press #120#, you will hear the announcement of IP address of LAN port, or press #126# to get WAN port IP address.
FXO please following under step:
1. You can get a PSTN line and connect to the L1 FXO port.
2. Use another PSTN phone to dial the PSTN number (in step 1you connected on FXO-08), you will hear a second dial tone or greeting (please dial extension number).
3. Press #126# on the phone set, and you will hear an IVR announcing the current IP address of the WAN port.
4. Press #120# on the phone set, and you will hear an IVR announcing the current IP address of the LAN port.
Built-in Call Hold Music System built-in music of call hold, you
can Enable/Disable this feature.
DTMF Duration Specify the DTMF tone duration.
DTMF Interdigit Time Specify the interval of DTMF digit
Page 41
26xx Technical Manual EN-V106d
40
Ring Time Limit ( 10~600sec ) (FXS only)
Specify the limitation of Ring time for incoming call, when the ring is over the limit, system will drop the call. The default range is 10~600sec.
Disconnect Singal Detcetion Disable
Polarity Reversal When enable the Polarity Reversal Detection, WG26xx (FXO) will use the polarity reversal as the answer signal and polarity normal as the hang-up signal for FXO outgoing call. Loop Current Drop Use line current drop as the disconnect signal or not. Both Enable polarity reversal and current drop simultaneously.
Disconnect Singal Generation Disable
Polarity Reversal Enabling polarity reversal, 26xx will reverse the line polarity when VOIP side is disconnected. Loop Current Drop This feature is used when the 26xx (FXS) are connected with answering machines. When the remote site disconnects, the system will drop FXS port’s voltage to 0, and make the answering machines disconnect.
1. Press the “Apply” button (at the bottom) after you finish to save changes.
2. Press the “Reboot” button to apply the changes.
Page 42
26xx Technical Manual EN-V106d
41
3.4.2 SNTP Setting
SNTP mode Select the SNTP mode : On or Off
SNTP server address Specify the SNTP server address for
time synchronization.
Time Zone -GMT Select the Time Zone of your location
Current Time Display the time with year/month/date
/hour/minute /second when you select the SNTP mode with “ON”.
1. Press the “Apply” button (at the bottom) after you finish to save changes.
2. Press the “Reboot” button to apply the changes.
Page 43
26xx Technical Manual EN-V106d
42
3.4.3 Codec Setting
Codec Priority You can specify the priority of the
codec from First to Fifth (first being the highest priority and Fifth being the lowest). You can choose the following codec’s:
G711U G711A G723 G729A G726
Codec Packet Size You can specify the packet size in the
drop down list for each particular codec, you can choose the following:
G711U 20,40,60
G711A 20,40,60
G723 30,60,90
G729A 20,40,60
Page 44
26xx Technical Manual EN-V106d
43
G726 20,40,60
Bandwidth Required When you select the codec packet size
shown above, system will set default requirement of bandwidth.
1. Press the “Apply” button (at the bottom) after you finish to save changes.
2. Press the “Reboot” button to apply the changes.
Page 45
26xx Technical Manual EN-V106d
44
3.4.4 Voice Setting
Jitter Buffer
Minimal Delay Specify the minimal delay of the jitter
buffer. The range is 0~150 ms and the default setting is 0 ms.
Maximal Delay Specify the maximal delay of the jitter
buffer. The range is 0~200 ms and the default setting is 200 ms.
OPTFactor Specify the dynamic jitter buffer frame
error/delay optimization factor, the range is 0~13.
VAD Enable/Disable the VAD (Voice Activity
Detection) feature. This is supported on all codices that the FXS-FXO equips.
Echo cancellation Enable/Disable the echo cancellation
feature. The default setting is “Enable”.
Local voice volume Specify the volume gain of the voice in
Page 46
26xx Technical Manual EN-V106d
45
the local side (+5~-20 db, default is -3 db).
Remote receive volume Specify the volume gain of the voice in
the remote side (+5~-20 db, default is
-3 db, default is -3 db).
DTMF volume Specify the volume gain of the DTMF
(+3~-32 db, default is -10 db).
1. Press the “Apply” button (at the bottom) after you finish to save changes.
2. Press the “Reboot” button to apply the changes.
Page 47
26xx Technical Manual EN-V106d
46
3.4.5 Tone Setting
Dial tone Specify the pattern of the Dial tone,
you can adjust the high frequency, low frequency, high level, low level, the On and Off time for tone 1 and 2.
Ringback tone (FXS only) Specify the pattern of the Ringback
tone, you can adjust the high frequency, low frequency, high level, low level, the On and Off time for tone 1 and 2.
Busy tone Specify the pattern of the Busy tone,
you can adjust the high frequency, low frequency, high level, low level, the On and Off time for tone 1 and 2.
Call-waiting (FXS only) Specify the pattern of the call-waiting
tone, you can adjust the high frequency, low frequency, high level, low level, the On and Off time for tone 1 and 2.
Voice-Notify (for FXS+PSTN only) Specify the pattern of the Voice-Notify,
you can adjust the high frequency, low frequency, high level, low level, the On
Page 48
26xx Technical Manual EN-V106d
47
and Off time for tone 1 and 2.
ROH Tone (FXS only) Specify the pattern of the ROH Tone,
you can adjust the high frequency, low frequency, high level, low level, the On and Off time for tone 1 and 2. The ROH tone is a single high frequency tone used to warn users that their phone is not placed on-hook (hang up) correctly.
Disconnect tone 1 Specify the pattern of the disconnect
tone for disconnect tone 1 (first set), you can adjust the high frequency, low frequency, high level, low level, the On and Off time for tone 1 and 2.
P.S. If the disconnect tone only has single frequency, please set it to low frequency. If the disconnect tone only has single cadence, please set it to Tone 1.
Disconnect tone 2 Specify the pattern of the disconnect
tone for disconnect tone 2 (second set), you can adjust the high frequency, low frequency, high level, low level, the On and Off time for tone 1 and 2.
P.S. If the disconnect tone only has single frequency, please set it to low frequency. If the disconnect tone only has single cadence, please set it to Tone 1.
1. Press the “Apply” button (at the bottom) after you finish to save changes.
2. Press the “Reboot” button to apply the changes.
Page 49
26xx Technical Manual EN-V106d
48
3.4.6 Phone Setting
Primary Ringing
Ringing Frequency Specify the Ringing frequency value.
ringing frequency : 15~100 (Unit : Hz)
Ringing ON Specify the Ringing ON value.
ringing ring ON : 0~8000 (Unit : ms)
Ringing OFF Specify the Ringing OFF value.
ringing ring OFF : 0~8000 (Unit : ms)
Ringing level Specify the ringing level.
ringing level : 0 ~ 94 (Unit : V)
Flash low Specify the value of the flash (low).
: 60~2000 (Unit : ms). If the phone-set’s flash time is smaller than the Flash Low setting, the flash will be ignored.
Flash high Specify the value of the flash (high).
: 60~2000 (Unit : ms) If the phone-set’s flash time is larger than the Flash high setting, the flash
Page 50
26xx Technical Manual EN-V106d
49
will be handled as hang-up.
Secondary Ringing (FXS only) Note: The feature will be enabled automatically when the Min. Digit Count has been enabled and specified. It is used to have different ring cadence when the incoming caller number is shorter than the setting of “Min. Digit Count”
Ringing Frequency Specify the Ringing frequency value.
ringing frequency : 15~100 (Unit : Hz)
Ringing ON Specify the Ringing ON value.
ringing ring ON : 0~8000 (Unit : ms)
Ringing OFF Specify the Ringing OFF value.
ringing ring OFF : 0~8000 (Unit : ms)
Ringing level Specify the ringing level.
ringing level : 0 ~ 94 (Unit : V)
Min. Digit Count Specify the minimum digit count
(1~10, 0: Disable), this feature is used to change the ringing frequency by detecting the digit length of incoming calls’ number. When the digit length of an incoming caller number is greater than the specified setting, the system will use primary ringing. If the digit is less than the specified setting, the system will use the secondary ringing.
Country Specify the ringing standard to use.
1. Press the “Apply” button (at the bottom) after you finish to save changes.
2. Press the “Reboot” button to apply the changes.
Page 51
26xx Technical Manual EN-V106d
50
3.4.7 Digit Manipulation
Digit Manipulation Editor FXO: This DM group is used for FXO incoming
call.
FXS: This DM group is used for FXS dialing
out.
VOIP: This DM group is used for VOIP
incoming call.
1-4: These DM groups can be used for
routing table.
Matched Prefix: The prefix to be matched
length for DM. The longest prefix will be matched first.
Matched min Length: Set to 0 for ignoring the
length. The other 1-32 are the length to be matched longest as a condition.
Start Pos: The start position to be replaced. Stop Pos: The stop position to be replaced. Replace Value: The value to replace.
Example
prefix Min
Len
Start
pos
Stop
pos
Replace
Value
Test DNIS Result DNIS
886 0 0 0 002 8862123456 0028862123456
886 12 0 0 002 8862123456 8862123456
Page 52
26xx Technical Manual EN-V106d
51
886 0 2 5 002 8862123456 8800223456
886 0 30 30 002 8862123456 8862123456002
886 0 1 6 8862123456 83456
Note: The DM Group 1~4 can have the feature to delay the dialing by added a “p” into the replace value. It might be useful, if you want to wait for a while and dial the second part of DTMF for calling out. Each “p” represents 2 seconds delay. For example: 822265699ppp1234; it will first dial 82265699 and wait to 6 sec to dial 1234.
1. Press the “Apply” button (at the bottom) after you finish to save changes.
2. Press the “Reboot” button to apply the changes.
Page 53
26xx Technical Manual EN-V106d
52
3.4.8 Dial Plan
Dial Plan Editor Using this feature, users can specify
the number that will be immediately dialed out without having to press the “#” (at the end of the dialed number) on the keypad or until the dial time timeout period. The number can be specified depending on the length of the dialed number, or the prefix of the dialed number. For example, if the user sets:
First Example
Function: Enable Leading digit: 02 Total Digit count: 10
If the user dials a 10 digit number with a prefix of 02 (e.g. 0282265699), the WELLGATE 26XX will immediately detect it and dial this number straight away.
Second Example
Function: Enable
Page 54
26xx Technical Manual EN-V106d
53
Leading digit: Total digit count: 8
If the user dials an 8 digit number (e.g.
82265699), the WELLGATE 26XX will
immediately detect it and dial this number straight away.
Third Example
Function: Disable Leading digit: 02 Total digit count: 10
If the user set the Function parameter as “Disable”, the call number with a length of 10 digits and a prefix of 02 will proceed as normal. The user will need to wait until dial timeout period for the call to be made, or press the “#” on the keypad at the end of the dialing number to make the call.
You can configure up to 50 entries in the Dial Plan.
1. Press the “Apply” button (at the bottom) after you finish to save changes.
2. Press the “Reboot” button to apply the changes.
Page 55
26xx Technical Manual EN-V106d
54
3.4.9 Call routing Editor
Call Routing Status: enable or disable this
routing
Prefix: matched DNIS (called
number) prefix.
Min Length: matched DNIS
minimum length. This DM can only be executing when the received DNIS is longer than it.
Route to: The outgoing call type
could be (FXO / FXS / VOIP /P2P ) Backup route to: If primary route is unable to reach the destination, whether to use the backup routing or not. The backup outgoing call type could be (FXO / FXS / VOIP /P2P) which require being different as the same type of primary route.
DM Group: The DM group here
can be used as the DM after routing rule was selected. It is useful especially when you have different dialing plan for backup route.
Page 56
26xx Technical Manual EN-V106d
55
3.5 Management
3.5.1 Provision Server
Note: The provisioning server is supported by working with WellEMS 9510 only.
. If you need this requirement, Please contact Welltech for availabilities.
Provision server Mode Enable/Disable provision function
Provision server IP address Specify the Provision Server’s IP
address.
Provision server port Specify the Provision server port
Provision cycle time Specify the cycle time of the
provisioning.(unit: sec)
Provision default time Specify a scheduled time in a day
1. Press the “Apply” button (at the bottom) after you finish to save changes.
2. Press the “Reboot” button to apply the changes.
Page 57
26xx Technical Manual EN-V106d
56
3.5.2 Save-Reload setting
Export File Click the “Export” button to export
“user.cfg” data
Import File Specify the file path and file name to
Import the configure data.
1. Press the “Reboot” button to apply the changes.
Page 58
26xx Technical Manual EN-V106d
57
3.5.3 Voice File
Voice File Type Voice files type to be uploaded. It could
be greeting or hold tone.
Upload File Specify the file path and file name to
upload. Please make sure that the file format needs to be G.711U, 8K, 8 bits raw file.
Page 59
26xx Technical Manual EN-V106d
58
3.5.4 Upgrade Firmware
Http Upload Specify the location of the firmware for
uploading through Http.
1. Under Device Management => Software Upgrade web menu, specify the location of the firmware by clicking the Browse button next to the Http Upload text box.
2. You will be prompted with a window requesting the location of the firmware.
3. Locate the firmware that is stored in your hard drive.
4. Once located, click the Open button.
5. Back in the web configuration menu, press the Start button (next to the Http Upload’s browse button) to execute the upgrade process.
6. Please wait while the device updates itself with the firmware.
7. After the update process is finish, you will be taken to a web page indicating that it was successful (see figure below).
Note: For consistency, it is recommended to reload default setting every time you update the firmware on the WELLGATE 26XX. However, you will lose all the settings configured on the WELLGATE 26XX except Network configuration. For more details on reload default setting, please refer to the next page below.
Page 60
26xx Technical Manual EN-V106d
59
3.5.5 Reset to Default
Users can restore back to factory default settings using this feature. The password of the account and the network configurations are the things that will not be changed when this feature is executed.
Page 61
26xx Technical Manual EN-V106d
60
3.5.6 Network Status
Connection mode Displays the current connection mode.
Current IP address Displays the current IP address of the
WAN port.
Subnet mask Displays the current subnet mask’s IP.
Default gateway Displays the current default gateway’s
IP.
Primary DNS address Displays the current primary DNS
address.
Second DNS address Displays the current secondary DNS
address.
WAN MAC Displays the MAC address of the WAN
port.
Page 62
26xx Technical Manual EN-V106d
61
3.5.7 Version Info.
Boot version Displays the current boot version
loaded on the WELLGATE 26XX.
Post version Displays the current post version
loaded on the WELLGATE 26XX.
Application version Displays the current application
version loaded on the WELLGATE 26XX.
Page 63
26xx Technical Manual EN-V106d
62
3.5.8 Port Status
Refresh Interval Time to update the status
Item Displays the corresponding port
number.
Port Type Displays the port type (FXS, FXO) of
the corresponding port number.
Enable Whether the port is enabled or disable.
Plug Whether PSTN is connected to the FXO
port or not
Status Displays the status of the port.
Status Time Status updated time
Register Proxy Displays the registration status of the
corresponding port number. if the port Register success it will display “Yes”.
Caller ID Calling party ID.
Called ID Called party ID.
Codec Voice Codec to be used
Page 64
26xx Technical Manual EN-V106d
63
3.5.8 Password
Username Select the type of user name that you
would like to configure the password for, you can choose the following:
root user
Current password Specify the current password for the
user selected in the drop down list above.
New password Specify the new password for the user
selected in the drop down list above.
Confirm new password Repeat the new password again for
confirmation.
1. Press the “Apply” button (at the bottom) after you finish to save changes.
2. Press the “Reboot” button to apply the changes.
Page 65
26xx Technical Manual EN-V106d
64
3.6 Rebooting the system
Executing this function will reboot the whole system, when configuration changes are made to the device, it needs to be rebooted for the changes to take effect (see figure below).
Page 66
26xx Technical Manual EN-V106d
65
Appendix A: How to set the P2P call
Example1:
This example shows a way to do the P2P in between a 2608 and 2680 by using the call routing features.
Used IP address:
1. 2608 IP is 192.168.18.2
2. 2680 IP is 192.168.18.235
A. 2608 Configuration
Step 1: Disable proxy settings and apply it as follows
Step 2: Disable Register for all line and apply it.
Page 67
26xx Technical Manual EN-V106d
66
Page 68
26xx Technical Manual EN-V106d
67
Step 3: Create a prefix as follow to route the call to 2680 as follows. Reboot and try it. For this example, we are route 26801 to 2680’s first line, 26802 to 2680’s second line...etc. Since the first port of 2680 is the 5060 and second port is 5062, the setting as show as follows:
Page 69
26xx Technical Manual EN-V106d
68
B. 2680 configuration
Step 1: Disable proxy settings as below and apply it.
Page 70
26xx Technical Manual EN-V106d
69
Step 2: Disable register for all lines as follows and apply it.
Page 71
26xx Technical Manual EN-V106d
70
Step 3: Create prefix to route to 2608’s FXS port. Reboot and try it. For this example, we are route 260801 to 2608’s first FXS line, 260892 to 2608’s second FXS line...etc. Since the first port of 2608 is the 5060 and second port is 5062, the setting as show as follows:
Page 72
26xx Technical Manual EN-V106d
71
Example 2:
This configuration shows an example to use the hot line for p2p calling. It is useful when you want your FXS pickup a phone and calling to a predefined destination. A. 2608 configuration
Step 1: Disable proxy settings and apply it.
Page 73
26xx Technical Manual EN-V106d
72
Step 2: For the line need to do the P2P hot line, put hotline number as the format of “number@uri:port”. Apply and reboot it.
In this example, when FXS line 1 pickup the phone, it will be hot line to
[email protected]:5060. Line 3 will be route to
Page 74
26xx Technical Manual EN-V106d
73
B. 2680 configuration
Step 1: Disable proxy settings and apply it.
Page 75
26xx Technical Manual EN-V106d
74
Step 2: For the line need to do the P2P hot line, put hotline number as the format of “number@uri:port”. Apply and reboot it.
In this example, when FXO line 1 receives an incoming call, it will be hot line to
[email protected]:5060. Line 3 will be route to
Page 76
26xx Technical Manual EN-V106d
75
Example 3
This configuration shows an example for P2P calling to a representative number. When a PSTN call is coming to 2680 FXO port, it will start the call routing and make the p2p call to the representative number of 2608 which provides serial line hunting. The same as 2608 to route to 2680’s representative number.
A. Configuration 2608
Step 1: Check the primary proxy and representative number enable option, then setup the required parameters of the representative number. Apply it. Since the P2P call will be used for this representative number, uncheck the primary proxy and apply it.
Page 77
26xx Technical Manual EN-V106d
76
Step 2: Disable SIP registers for all lines and apply it.
Page 78
26xx Technical Manual EN-V106d
77
Step 3: Create a call routing entry for routing to 2680’s representative number as below. Reboot it to take effective. In this example, the call will be route to [email protected]:5076 (5076 is the port number or representative listened).
Page 79
26xx Technical Manual EN-V106d
78
B. 2680 Configuration
Step 1: Check the primary proxy and representative number enable option, then setup the required parameters of the representative number. Apply it. Since the P2P call will be used for this representative number, uncheck the primary proxy and apply it.
Page 80
26xx Technical Manual EN-V106d
79
Step 2: Disable sip register for all lines and apply it.
Page 81
26xx Technical Manual EN-V106d
80
Step 3: Create a call routing entry for routing to 2608’s representative number as below. Reboot it to take effective. In this example, the call will be route to [email protected]:5076 (5076 is the port number or representative listened).
Loading...