All rights reserved © TimeLink microsystems
3.3.2. SSH access
This service provides access to the device from another computer in safe mode.
Only the user « maintenance” has authorization to connect to the equipment. After connecting a shell is opened
on the machine. So it should be paid to actions from this moment on pain of no longer serve the primary functions
of the equipment.
Possible actions from the shell are:
• to update the system software
• change a user's password
• restart or shut down equipment
• log in as 'root'
The default password is « tms2000 ».
3.3.2.1. Updations the system
The system update is done using the tool 'update' provided.
Refer to the section Maintenance to see how.
3.3.2.2. Changing password
To change the password of a user you must use the command 'passwd [<user>]'. You will be requested the new
password and it will be written in the SD card file.
Note: When the user “maintenance” changes his password, it must respect the following rules:
• length of 8 characters at least
• at least three of four criteria: a tiny (a-z), a capital letter (A-Z), a number (0-9), a special character ($, @, ...)
• The password must be sufficiently different from the current password
• The password cannot be the host name (including permutation of characters, different case).
Failure to comply with these rules results in the rejection of the password.
For the root user, the non compliance is indicated but the password is nonetheless forced.
3.3.2.3. Restart or shutdown the equipment
These functions allow to restart or to stop safely the equipment. You first need to be root to enable these features
(see below).
To restart type 'reboot' and stop type 'poweroff'. After a 'poweroff' you can turn off the equipment.
3.3.2.4. Become 'root'
This function allows the user to change his identity in that of root.
For this type '/ tools / su' and enter the password for the root user (default: tms2000 ").