HP 8/20q, SSCM 2.10 Release Note

Page 1
HP StorageWorks Simple SAN Connection Manager 2.10 release notes
Part number: 5697-8050 Sixth edition: February 2009
Page 2
Legal and notice information
© Copyright 2008-2009 Hewlett-Packard Development Company, L.P.
Confidential computer software. Valid license from HP required for possession, use or copying. Consistent with FAR 12.211 and 12.212, Commercial Computer Software, Computer Software Documentation, and Technical Data for Commercial Items are licensed to the U.S. Government under vendor's standard commercial license.
The information contained herein is subject to change without notice. The only warranties for HP products and services are set forth in the express warranty statements accompanying such products and services. Nothing herein should be construed as constituting an additional warranty. HP shall not be liable for technical or editorial errors or omissions contained herein.
Java is a US trademark of Sun Microsystems, Inc.
Microsoft and Windows are U.S. registered trademarks of Microsoft Corporation.
Red Hat and Enterprise Linux are registered trademarks of Red Hat, Inc., in the United States and other countries.
Page 3
Description
The HP StorageWorks Simple SAN Connection Manager (SSCM) is a GUI-based management application for basic management of Storage Area Network (SAN) components, such as Host Bus Adapters (HBAs), switches, and storage arrays. For managing storage arrays, the SSCM uses Microsoft's Virtual Disk Service (VDS). SSCM provides simplified storage management for VDS-compliant storage devices in a single, integrated, wizard-based user interface.
Products and devices supported
SSCM supports the following products and devices:
• HP StorageWorks 8/20q Fibre Channel Switch
• HP StorageWorks EVA4x00/6x00/8x00 with XCS 6.110 or later
• HP StorageWorks EVA4400
• HP StorageWorks MSA1x00 with V7.00 or later firmware
• HP StorageWorks MSA2000fc
Operating system
The Simple SAN Connection Manager supports Microsoft Windows Server 2003 R2 operating system with Service Pack 2.
Supported client operating systems include the following:
• Microsoft Windows Server 2003 with SP2
• Microsoft Windows Server 2008
• SUSE Linux Enterprise Server (SLES) 9 and 10
• Red Hat Enterprise Linux (RHEL) 4 and 5
• VMware ESX 3.5
• HP-UX 11.23, 11.31
Prerequisites
This section specifies requirements for the use of the Simple SAN Connection Manager.
System requirements
Ensure that the server running your management software (management station) meets the following minimum requirements (for supporting the software, including SSCM and other HP software):
• Microsoft Windows Server 2003 R2 operating system with Service Pack 2
• 512 MB of memory
• 200 MB of disk space
• One 2.0-GHz processor
• One CD-ROM drive; one Ethernet port
HP StorageWorks Simple SAN Connection Manager 2.10 release notes 3
Page 4
• One or more PCI-e slots for the HP StorageWorks 81Q PCI-e Fibre Channel HBA (or other supported
QLogic FC HBA)
• Java Runtime Environment (JRE) 1.5 or later
• Internet browser: Microsoft Internet Explorer (IE), Netscape Navigator, or Mozilla Firefox
Installation instructions
For detailed installation instructions, see the HP StorageWorks Simple SAN Connection Manager user guide available on the HP website:
nl
http://www.hp.com/go/8Gb-SSC.
Important information
This section provides information regarding installation, Enterprise Virtual Array (EVA), and Modular Smart Array (MSA) issues, the switch, and other important matters relating to the HP Simple SAN Connection Manager.
Installation issues
• Network installations: The SSCM installer does not support installation over a direct network share
using \\<ip or system-name>\share. Attempting to install SSCM in this manner results in the following error:
Internal Error This installation wizard has experienced an error. Please contact your software vendor with the error code below. Error: File copy failed. Error Code (23).
Workaround: Install SSCM from a local CD, a local disk, or a network share that is mapped to a drive letter.
• Updating from SSCM 1.00: When upgrading from SSCM 1.00 to SSCM 2.10, the following error
message appears and the installation halts:
An xpath query failed. Please view the error log for specifics about the error. Error Code: 16777377
Workaround: To resolve this issue:
1. Delete all files in one of the following directories (depending on the architecture (x64/x86)
of the operating system):
• C:\Program Files (x86)\Hewlett-Packard\InstallWizard\HP Storage-
Works Simple SAN Connection Manager
• C:\Program Files\Hewlett-Packard\InstallWizard\HP StorageWorks
Simple SAN Connection Manager
2. Insert the SSCM 2.10 CD and start the installation.
• Linux install issue on RHEL 5: Under specific distributions, such as Red Hat Enterprise Linux 5, the
installation CD is auto-mounted using the following CD Label:
# /media/HpInstallx.x/
If this occurs, the CD may get mounted with the no execution flag, causing the installation script to fail. Installation failure may be indicated by the error message:
# ./install_smb.sh
bash: ./install_smb.sh: /bin/sh: bad interpreter: Permission denied
4
Page 5
Workaround: Manually unmount the installation CD. For example, if the CD was auto-mounted in
/media/HpInstallx.x, issue the following commands to remount the CD:
# unmount /media/HpInstallx.x
# mkdir —p /mnt/cdrom
# mount /dev/cdrom /mnt/cdrom
If the unmount command fails with a busy warning, make sure you have closed all applications and consoles that could be using the CD media.
• On Microsoft Windows Server 2008 the MSA2000 uses the native Microsoft MPIO. Perform this
procedure for all Windows 2008 systems in your SAN to configure MPIO.
nl
To activate MPIO:
nl
1. Click Start > Settings > Control Panel.
2. Double-click the MPIO icon.
3. Select the second tab, Discover Multi-Paths.
4. The MSA2000 appears in the Others section in the Device Hardware ID.
5. The MSA2000 should appear as HP LOGICAL VOLUME. Select this entry and then click Add.
• Windows Server 2008 upgrade issue: Performing an upgrade from a previous installation on the
Windows Server 2008 will cause two components (MSA2000 MPIO and SES drivers) to fail to install.
Workaround: These components are not needed by the Windows Server 2008. Please ignore the failure of those components during an upgrade from a previous version.
EVA-specific issues
• EVA configuration: The SSCM has the following restrictions when managing an EVA array:
• Host definitions cannot be removed from the EVA by the SSCM.
• Once a port (HBA) has been added to a host definition, the port cannot be removed by the
SSCM.
• HP Command View EVA offers great flexibility in how a user can configure an EVA. However,
the SSCM may not operate as expected if an array was configured using HP Command View EVA. A user should use SSCM or HP Command View EVA to configure an array, but not both.
NOTE:
Using HP Command View EVA to delete unwanted entries in an array's configuration (such as a host or port that has been physically removed) is supported.
• EVA login account: If the EVA login user name is changed, use the HP VDS Configuration Utility
for EVA to re-enter the new user name and password. This utility is installed with the EVA VDS hardware provider and can be launched from Start > Programs > Hewlett-Packard > Hardware Providers.
• EVA4400 not discovered on startup: EVA4400 is not discovered on the startup of SSCM.
Workaround: If your SAN contains an EVA4400, ensure that all HP Command View installations within that SAN are running HP Command View 8.0 or later.
HP StorageWorks Simple SAN Connection Manager 2.10 release notes 5
Page 6
MSA1x00-specific issues
• MSA LUN name between Array Configuration Utility (ACU) and SSCM does not match: LUN names
created by the MSA ACU and the SSCM do not match when displayed. The ACU LUN name is partly shown in SSCM as LUN identification.
• MSA hardware provider memory leak: The HP MSA hardware provider installed with the HP
StorageWorks SSCM has a memory leak that may increase over time when VDS operations are exercised. To reclaim lost memory, close SSCM to unload the MSA hardware provider. Check the HP website for updates to the HP MSA hardware provider.
• Hosts connecting to MSA storage subsystems may not be discovered by SSCM during fabric changes:
When MSA responds to a fabric event, such as zoning changes, the HBA agent software takes some time to discover the MSA storage subsystem. When the system is in this state and SSCM is launched, it may not discover the host because its HBA agent software is still busy.
Workaround: If this occurs, either re-launch SSCM after a few minutes, or refresh the server list, and/or manually add the server.
Switch issues
• SSCM and switch passwords: If the switch password is set up or updated using the Simple SAN
Connection Manager, SSCM remembers the password and will not prompt for one whenever a switch operation is initiated. However, if you set up or change the password in another application (such as QuickTools), SSCM cannot retrieve the switch information when launched. SSCM shows the default generic switch name, and any switch operation that you request will prompt for the password.
• SSCM shows switch zoning information as Unknown for vendor and device type: The SSCM uses
the switch zoning component Fibre Channel worldwide port name (WWPN) to match the vendor and device type. If the switch zoning is not WWPN-based, it shows the information as Unknown in the Switch Zoning Information dialog box.
Other issues
• The graphics for the MSA and EVA are not accurate: The storage subsystem graphics in the Manage
Storage Subsystem dialog box are meant only as an abstract representation of the MSA and EVA storage subsystems and their enclosures and drives. The graphic images do not actually reflect the physical layout of the subsystems.
• LUN multipath Information: A LUN's multipath information is available only if that LUN is presented
to the management host where the VDS hardware provider and SSCM are installed and running.
Workaround: To obtain multipath information for LUNs presented to other hosts, issue the hpdsm devices command from either the EVA DSM Command Line Interface (CLI) or the MSA DSM CLI
on that host. To launch the EVA DSM, select Start > Programs > Hewlett-Packard > EVA DSM > HPDSM CLI. To launch the MSA DSM, select Start > Programs > Hewlett-Packard > MSA DSM > HPDSM CLI
• SSCM Startup: SSCM may take several minutes to start up. The size of your SAN and the config-
uration of your storage directly affects the startup time. SSCM uses an Ethernet broadcast mechanism to discover the hosts and their HBAs in the SAN. If
there are a large number of hosts in the network responding to this broadcast, the host discovery process may take some time to complete.
• SSCM fails to start: If the user installs SSCM with the MSA only option and HP Command View
EVA is installed, the SSCM will be unable to start. The error RegOpenKeyEx failed with error 2: The system cannot find the file specified is displayed when the user attempts to start the SSCM.
6
Page 7
Workaround: To correct this problem, reinstall the SSCM and select the EVA only or the EVA and MSA option if an array is present in the configuration. If no EVA is present, uninstall the HP Command View EVA suite.
• IA64 BIOS Update: The HBA driver update feature for Windows on IA64 is not supported in SSCM.
• Format Drive Message: During partition creation and formatting for LUNs for Windows Server
2008, a Windows Format Drive message pops up to confirm formatting or cancel. Workaround: None. This message will not impact the function, but a new pop-up appears for
each new partition. Hit cancel to close the window.
• Server name changes: If the name or other attribute of a server being managed by SSCM is
changed independent of SSCM, SSCM continues to display the original name even after restarting. The server change is not detected until a Server Refresh is done because SSCM matches up the HBA WWN with the saved server data. This saved data is not updated until a new broadcast or FDMI refresh is done. A server refresh is not performed on application start up or asynchronously while the application is open.
Workaround: To see the new server name, use the Refresh the Server List option.
• Creating partitions on the management station: Deleting LUNs presented to the management station
may cause errors if new LUNs are created right after the old LUNs are deleted. The new LUNs may not be initialized and a drive letter not assigned.
Workaround: Reboot the management station after deleting any LUNs that were presented to the management station. Then perform the template deployment or creation of any new LUNs.
• Default zoning with null name error: If you create default zoning in SSCM with a null name
and apply the changes, an error message states Create default zone error: Zone set creation failed and the current zones on the switch in QuickTools are deleted.
Workaround: When setting the default zoning, you must specify a zone name, otherwise, applying the new default zoning will fail and will subsequently delete any previously existing zones.
HP StorageWorks Simple SAN Connection Manager 2.10 release notes 7
Page 8
8
Loading...