This chapter provides sample hardware and software configurations for specific dial scenarios used by
telcos, Internet service providers (ISPs), regional Bell operating companies (RBOCs), inter-exchange
carriers (IXCs), and other service providers. Each configuration in this chapter is designed to enable IP
network traffic with basic security authentication.
The following scenarios are described:
• Scenario 1—Small- to Medium-Scale POPs
• Scenario 2—Large-Scale POPs
• Scenario 3—PPP Calls over X.25 Networks
NoteIn all of these example scenarios, you can replace the Cisco AS5200 access server with a
Cisco AS5300 access servers, Cisco AS5800 access servers, or Cisco AccessPath routers.
This hardware exchange provides higher call density performance and increases the
number of PRI interfaces and modem ports on each chassis.
Small- to Medium-Scale POPs
Many small-to-medium-sized ISPs configure one or two access servers to pro vide dial-in access for their
customers. Many of these dial-in customers use individual remote perso nal computers (PCs) th at are not
connected to LANs. Using the Windows 95 dialup software, remote clients initiate analog or digital
connections using modems or home office ISDN BRI terminal adapters.
This section provides three types of single user dial-in scenarios for service providers:
• Individual Remote PCs Using Analog Modems
• Individual PCs Using ISDN Terminal Adapters
• Mixture of ISDN and Analog Modem Calls
NoteBe sure to include your own IP addresses, host names, and security passwords
where appropriate. The following sample configurations assume that the dial-in clients are
individual PCs running PPP, connecting to an IP network, and req uiring only basic security
authentication.
ISPs can configure a single Cisco AS5200 access servers to receive analog calls from remote PCs
connected to modems, as shown in Figure 51. The point of presence (POP) at the ISP central site could
also be a Cisco 2511 access server connected to external modems.
Network Topology
Figure 51 shows a small-scale dial-in scenario using modems.
Figure 51Remote PC Using an Analog Modem to Dial In to a Cisco AS5200 Access Server
C running Windows 95
nd accessing
he Internet
Analog calls
Telco and ISP Dial Scenarios and Configurations
Internet
Analog
modem
Standard telephone
network (POTS)
T1 PRI
Cisco AS5200
used to provide
Internet access
by an ISP
S6537
Running Configuration for ISDN PRI
The following example runs on the Cisco AS5200 access server, as shown in Figure 51, which enables
remote analog users to dial in:
!
version 11.2
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
hostname NAS
!
aaa new-model
aaa authentication login console enable
aaa authentication login vty tacacs+
aaa authentication login dialin tacacs+
aaa authentication ppp default tacacs+
aaa authentication ppp dialin if-needed tacacs+
enable secret cisco
!
async-bootp dns-server 10.1.3.1 10.1.3.2
isdn switch-type primary-5ess
!
line aux 0
login authentication console
line vty 0 4
login authentication vty
transport input telnet rlogin
!
end
Some service providers use a remote TACACS+ or RADIUS security serv er in this dial-in scenario. The
following example shows a TACACS+ entry that appears in the configuration file of a remote security
server:
user = PCuser1 {
}
Telco and ISP Dial Scenarios and Configurations
login = cleartext "dialpass1"
chap = cleartext "dialpass1"
service = ppp protocol = ip {
addr-pool = dialin_pool
}
service = exec {
autocmd = "ppp negotiate"
}
user = PCuser2 {
login = cleartext "dialpass2"
chap = cleartext "dialpass2"
service = ppp protocol = ip {
}
service = exec {
}
}
user = PCuser3 {
login = cleartext "dialpass3"
chap = cleartext "dialpass3"
service = ppp protocol = ip {
}
service = exec {
}
}
addr-pool = dialin_pool
autocmd = "ppp negotiate"
addr-pool = dialin_pool
autocmd = "ppp negotiate"
Running Configuration for Robbed-Bit Signalling
The following example shows a single Cisco AS5200 access server configured to support remote client
PCs dialing in with analog modems over traditional T1 lines. Digital ISDN calls do not transmit across
these older types of channelized lines. The conf iguratio n assumes that the client can dial in and connect
to the router in either terminal emulation mode (text only) or PPP packet mode.
DNC-308
NoteThe following configuration works only for analog modem calls. It includes no serial
D-channel configuration (Serial 0:23 and Serial 1:23).
ip classless
!
dialer-list 1 protocol ip permit
!
line con 0
login authentication console
line 1 48
autoselect ppp
autoselect during-login
login authentication dialin
modem DialIn
line aux 0
login authentication console
line vty 0 4
login authentication vty
transport input telnet rlogin
!
end
Individual PCs Using ISDN Terminal Adapters
Telco and ISP Dial Scenarios and Configurations
Network Topology
ISPs can configure a single Cisco AS5200 access server to receive digital multilink calls from remote
PCs connected to terminal adapters, as shown in Figure 52. The POP at the central site of the ISP can be
any Cisco router that supports ISDN PRI, such as the Cisco 4700-M router loaded with a channelized
T1 PRI network module.
Figure 52 shows a small-scale dial-in scenario using terminal adapters.
Figure 52Remote PC Using a Terminal Adapter to Dial In to a Cisco AS5200 Access Server
Internet
ome office remote
C running Windows 95
BRI
Terminal
adapter
Digital calls
ISDN network
T1 PRI
Cisco AS5200
used to provide
Internet access
S6536
T o confi gure one Cisco AS5200 to accept both incoming ISDN and analog calls from indi vidual terminal
adapters and modems, see the section “Mixture of ISDN and Analog Modem Calls” later in this chapter.
The following example configures a Cisco AS5200 access server to enable PCs fitted with internal or
external terminal adapters to dial in to an IP network. The terminal adapter configuration is set up for
asynchronous to synchronous PPP conversion. In some cases, PPP authentication must be set up for the
Password Authentication Protocol (PAP). Some terminal adapters only support PAP authentication.
!
version 11.2
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
hostname NAS
!
aaa new-model
aaa authentication login console enable
aaa authentication login vty tacacs+
aaa authentication login dialin tacacs+
aaa authentication ppp default tacacs+
aaa authentication ppp dialin if-needed tacacs+
enable secret cisco
!
async-bootp dns-server 10.1.3.1 10.1.3.2
isdn switch-type primary-5ess
!
controller T1 0
framing esf
clock source line primary
linecode b8zs
pri-group timeslots 1-24
!
controller T1 1
framing esf
clock source line secondary
linecode b8zs
pri-group timeslots 1-24
!
interface Loopback0
ip address 10.1.2.254 255.255.255.0
!
interface Ethernet0
ip address 10.1.1.10 255.255.255.0
ip summary address eigrp 10 10.1.2.0 255.255.255.0
!
interface Serial0
no ip address
shutdown
!
interface Serial1
no ip address
shutdown
!
interface Serial0:23
no ip address
encapsulation ppp
dialer rotary-group 0
dialer-group 1
no fair-queue
no cdp enable
!
interface Serial1:23
no ip address
encapsulation ppp
dialer rotary-group 0
dialer-group 1
no fair-queue
no cdp enable
!
interface Dialer0
ip unnumbered Loopback0
no ip mroute-cache
encapsulation ppp
peer default ip address pool dialin_pool
dialer in-band
dialer-group 1
no fair-queue
no cdp enable
ppp authentication chap pap dialin
ppp multilink
!
router eigrp 10
network 10.0.0.0
passive-interface Dialer0
no auto-summary
!
ip local pool dialin_pool 10.1.2.1 10.1.2.50
ip default-gateway 10.1.1.1
ip classless
!
!
!
dialer-list 1 protocol ip permit
!
line con 0
login authentication console
line 1 48
autoselect ppp
autoselect during-login
login authentication dialin
modem DialIn
line aux 0
login authentication console
line vty 0 4
login authentication vty
transport input telnet rlogin
!
end
ISPs can configure a single Cisco AS5200 access server to receive calls from a mixture of remote PCs
connected to terminal adapters and modems, as shown in Figure 53.
Figure 53Remote PCs Making Digital Calls and Analog Calls to a Cisco AS5200
unning Windows 95
nd making digital
alls in to the Internet
Terminal
adapter
BRI
Small- to Medium-Scale POPs
ISDN
Analog
Modem
ome office PC
unning Windows 95
nd making analog
odem calls in to
T1 PRI
ISP using a
Cisco AS5200
to provide
Internet access
Combination of Modem and ISDN Dial-In Configuration Example
The following example shows a combination of the modem and ISDN dial-in configurations. Using the
bearer capability information element in the call setup packet, the incoming calls are labeled as data or
voice. After the calls enter the access server, they are routed either to the serial configuration or to the
modems and group asynchronous configuration.