AppleShare 5-0-2 Quick Start Guide

Page 1
Important Information About AppleShare 5.0.2
AppleShare 5.0.2 has two improvements not mentioned elsewhere in the documentation:
m It is fully compatible with Mac OS 8. m It supports WebStar-compatible plug-ins.
Note: Several sections in this document instruct you to restart the Web server so that settings changes can take effect . To save time, read this entire document and make all changes before you restart the server.
Using WebStar plug-ins
Plug-ins add speed and functionality to your Web server. T hey act like CGI (Common Gateway Interface) scripts but are faster and more efficient. You can use plug-ins to
m record the number of visitors to your Web pages m process forms m access databases such as customer lists or product catalogs m conduct on-screen chats m check passwords m let users search for information on your Web site
You can purchase plug-ins from software vendors or download them from the Intern et.
Page 2
Installing plug-ins
nn
To install a plug-in, follow the instructions that came with the plug-in software.
If no directions came with the software, drag the plug-in to the Plug-Ins folder inside the current Web folder, chosen in the Web & File Sharing Settings window.
Setting aside memory for plug-ins
The do cumentation that came with your plug-in may tell you how much memory the plug-in needs to load and to work properly. (All the plug-ins in the Plug-Ins folder load when your Web server starts.)
Important Do not adjust the memory set aside for plug-ins by using the server’s I nformation dialog box. Instead follow the instructions in this section.
1 Open the Web & File Admin program. 2 Choose Web & File Server Settings from the Server menu.
The Web & File Server Settings window appears.
3 Choose Web Plug-Ins from the pop-up menu.
<<Picture “Web Plug-ins Settings PICT”>>
4 Increase the number in the box labeled Maximum Plug-in Memory Usage by the amount
of memory that your plug-in requires.
To increase this number, click the up arrow. The total in the box should be at least as large as the sum of required memory
for all plug-ins in the Plug-Ins folder, plus any special plug-ins that reside elsewhere. (See “Special Plug-in Settings,” later in this document.)
5 Click Save.
Before you save changes, you may want to read the next section and make changes to other settings.
2
Page 3
6 To make your changes take effect, restart the server.
If the server is running, choose Stop Web & File Server from the Server menu. Then choose Start Web & File Server from the Server menu.
Changing other plug-in settings
To change other plug-in settings, follow these instructions:
1 Open the Web & File Admin program. 2 Choose Web & File Server Settings from the Server menu.
The Web & File Server Settings window appears.
3 Choose Web Plug-Ins from the pop-up menu.
<<Picture “Web Plug-ins Settings PICT”>>
4 To enable plug-ins, click to put an X in the box labeled Enable Plug-ins. 5 To allow plug-ins to maintain a log of their actions, click to put an X in the box labeled
Enable Plug-in Logging.
6 To select special plug-ins to handle preprocessing, postprocessing, or error-handling
tasks, click the appropriate button and locate the plug-in you want to use.
See the next section for details.
7 Click Save. 8 To make your changes take effect, restart the server.
If the server is running, choose Stop Web & File Server from the Server menu. Then choose Start Web & File Server from the Server menu.
Special plug-in settings
AppleShare IP lets you activate specific plug-ins to handle preprocessing, postprocessing, and error-handling tasks.
Preprocessor plug-ins examine requests for information before your Web server acts on them. For example, the plug-in might display a password dialog box to make sure that a user who is trying to connect to your site is authorized to do so.
3
Page 4
Postprocessor plug-ins manipulate information after your Web server has been used, for example to file information about what internal links the most recent visitor activated.
Error plug-ins process information about problems such as “file not found” errors. This kind of plug-in might record the error in a log and send a message to the user suggesting what to do.
To activate a specific preprocessor, postprocessor, or error plug-in, follow these instructions:
1 Open the Web & File Admin program, if it’s not already open. 2 Choose Web & File Server Settings from the Server menu.
The Web & File Server Settings window appears.
3 Choose Web Plug-Ins from the pop-up menu. 4 Click the button next to the kind of plug-in you want to activate. 5 Locate the plug-in you want to activate, then click OK. 6 If you wish, repeat steps 4 and 5 to activate other plug-ins.
You can activate one of each special type.
7 To make your changes take effect, restart the server.
If the server is running, choose Stop Web & File Server from the Server menu. Then choose Start Web & File Server from the Server menu.
Seeing the plug-in log file
Plug-ins can maintain information about what happens when they execute. This information varies from plug-in to plug-in, but it’s all stored in the same text file.
nn
To see the log information, double-click the file named “Plug-In Messages” in the HTTP Logs folder.
The H TTP Logs folder is in the AppleShare IP Preferences folder within the System Folder’s Preferences folder.
4
Loading...